Disclaimer

I am not responsible if your devices send you back in time, explodes, implodes, bricks or flies into space from the use of any software I put up.

Search

Friday, November 20, 2015

OpenWrt Dec 2015 Release

Haven't been building for a few month, not that there was any major tweaks until now.
This release has more optimization, from my testing definitely an increase in performance.

The performance boost was the result from the findings that, apparently -mno-mips16 is not enough, need to further remove interlinks to strip the abomination of the mips16.

Compiling the powerpc with pthreads enabled have dependency missing from a few packages which I subsequently patched.

Full changes can be seen from my github repo.
Enjoy!

9 comments:

Sven said...

Thanks for this release.
What's the reason you are doing more releases of Barrier Breaker and have not switched to Chaos Calmer?

Admin said...

I think I will need a blog post to explain why.
But the gist is chaos calmer sucks big time.
Just download a copy off openwrt to see why.

Oleg Chomenko said...

AUG installation was generated an error:
Collected errors:
* opkg_download: Failed to download https://github.com/gwlim/Openwrt_Firmware/blob/master/TP-Link_TL-WR1043ND/Barrier_Breaker/Aug-2015-Image/packages/base/Packages.gz, wget returned 5.

due SSL certificate.

Was it fixed in Dec. release ?

Dlna Media said...

What's the reason you are doing more releases of Barrier Breaker and have not switched to Chaos Calmer?
I think I will need a blog post to explain why.
Can you explain to us, why?

Admin said...

@Oleg try wget --no-check-certificate

Oleg Chomenko said...

i know about, but can not figure-out how to add this option (skip cert. verif) to use opkg ....; using standard installation can avoid all headaches ... another option to move evrything to non secure we site ...

diglam said...
This comment has been removed by the author.
diglam said...

Hi,

My TP-Link TL-WR1043N/ND v1 connects to ISP by PPPOE over WAN port.
If I start to download something or start a connection test, WAN connection drops and later I see authentication failed message on system log when WAN tries to connect again.

But everything is ok on regular openwrt (14.07)

Do you have any idea, what can be reason?

thanks.

siddis said...

diglam:

Interfaces / WAN / Advances settings
LCP echo failure threshold: 80
LCP echo interval: 20